Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help with DK63

#1
Every time I slightly move my keyboard, I get the windows sound that it was unplugged then plugged back in. I made sure the cord was plugged all the way in. I am also seeing an issue where the keys will stop responding then a few minutes later it will type out what i typed. 

I have this issue with both wired and bluetooth. 

Are these common issues? I have uninstalled and reinstalled the software and reset the profile, but I have not made any changes to the keyboard upon receiving. Is there a way to do a factory res ton this keyboard?
Reply

#2
(07-31-2020, 07:09 AM)HisKingdomReigns Wrote: Every time I slightly move my keyboard, I get the windows sound that it was unplugged then plugged back in. I made sure the cord was plugged all the way in. I am also seeing an issue where the keys will stop responding then a few minutes later it will type out what i typed. 

I have this issue with both wired and bluetooth. 

Are these common issues? I have uninstalled and reinstalled the software and reset the profile, but I have not made any changes to the keyboard upon receiving. Is there a way to do a factory res ton this keyboard?
Try plugging the keyboard into a different USB port. I found that some of mine were VR ready USB port (3.1) and interfering with the keyboard. If that doesn't work and you've updated the software again, I'd say the keyboard is faulty.

In regards to the unresponsiveness, that's to do with the sleep feature on the keyboard. It disconnects after inactivity and takes time to reconnect causing the keyboard to send what you typed but with a delay. The software update is supposed to let you turn this off but it doesn't. 

I made a video discussing some of the issues this keyboard has and answers to questions in regards charging etc.  

https://youtu.be/eImSq6gpiyo
Reply



Forum Jump:


Users browsing this thread:
1 Guest(s)

Forum software by © MyBB Theme © iAndrew 2016